Базы данных Oracle - статьи


           

Здесь описаны некоторые советы по


Здесь описаны некоторые советы по возможному дальнейшему совершенствованию предложенного механизма экспорта данных в Excel.
Вместо предложенного формата файла, можно попробовать использовать sylk формат, описание которого можно найти в Интернет. Excel также понимает этот формат, предоставляющий большие возможности по форматированию данных.
В качестве первой строки в файл можно записывать заголовок окна формы. Получится своеобразный заголовок отчета в Excel.
Блок формы может содержать десятки, сотни тысяч записей, а то и больше. В таких случаях выгружать все записи блока - задача не реальная. Для таких случаев можно реализовать ограничитель на количество выгружаемых записей. Т.е. условием окончания записи в файл сделать не только достижение последней записи в блоке, но и дополнительно к этому, достижение максимально возможного количества записей для выгрузки, если таковое установлено.
В качестве значения ячейки можно передавать формулы. Для этого значение должно начинаться с символа "=". В формулах можно использовать арифметические операции и ссылки на ячейки, например вот так =A2+B2+C2. Но почему-то не получается использовать в формулах функции, например =СУММ(A2:A10). В приведенной реализации использование формул запрещено. Если значение начинается с символа "=", то оно дополняется пробелом слева.

Содержание  Назад  





Forekc.ru
Рефераты, дипломы, курсовые, выпускные и квалификационные работы, диссертации, учебники, учебные пособия, лекции, методические пособия и рекомендации, программы и курсы обучения, публикации из профильных изданий